Canon EOS 550D software and 10.8 Mountain Lion

I recently installed the Mountain Lion DP on my Late 2011 Macbook Pro and I love it. Sadly my Canon EOS software Utility will not work. I try to launch it and it says "Cannot be used with this version of the Operating System". Is there a fix or a way to get it to run? I downloaded the 10.7 Lion Update Installer but it gives me the issue "Don't have enough privilege to install. Log in as administrator and try again." I currently am the Admin on my mac so I have no clue why its saying this unless its just the buggy Dev Preview. Any ideas?

6937265923_2faf055873_medium

Screen Shot 2012-02-27 at 11.40.47 PM (via anthonylonas)