Is it possible to install 5.0.1 today if I'm still on 4.3.3?

Is it possible to install 5.0.1 today if I'm still on 4.3.3?

or Do did I miss my opportunity to get a new SHSH blob. I do have a blob but I think it's for 4.3.3...