8.1 Preview woes on Surface Pro

Hello Verge! I'm having some trouble here and I'm hoping someone can help.

I want to install the Windows 8.1 Preview on my Surface Pro, but I don't want to run it as my main OS. I figured I'd just dual-boot the preview with Windows 8 but that's where the trouble started. For the life of me I can't get the installer to boot.

I partitioned my SSD with Windows' built-in partition tool. I downloaded the English 64-bit 8.1 Preview ISO from Microsoft, then used the Windows 7 USB/DVD Download Tool to create a bootable flash drive of the installer. I tossed the drive into my Surface, tried to start it, but for some reason it skips the 8.1 installer and boots directly to Windows 8.

I've tried booting with both methods that Microsoft lists. I've held volume down while powering on, and I've tried using the Advanced Boot menu. Neither allows the installer to start. I thought maybe it has something to do with Secure Boot, so I disabled that from UEFI, but still no luck. I thought that the flash drive might've been the problem, so I used a different one (tested with an old 8GB Sandisk Cruzer Micro and a USB3 ADATA 64GB drive) but that still didn't fix it. Just to be sure, I tried booting both drives on two of my other older PCs, both of which run Windows 8 currently, and they boot just fine on those.

So basically I'm stumped. I really want 8.1 but I just don't have it in me to use it exclusively until it's finalized. Hopefully someone here can help me and I can finally get this working.