Users of Tumblr’s iOS app are advised to immediately install a new security update and change their passwords, says the company, following the discovery of a security vulnerability. (Passwords could be "sniffed" — intercepted on local networks — in some versions of the app.) A representative told The Verge that "earlier today, Tumblr was notified of a security vulnerability introduced in our iOS app," and immediately acted to close it and notify affected users. iOS 7 will bring automatic app updating to Apple’s platform, getting rid of the need to plead with people to install security updates once it arrives this fall. In the meantime, be sure to download version 3.4.1 of Tumblr from the App Store.